Kitfox Aircraft Stick and Rudder Stein Air Grove Aircraft TCW Technologies Dynon Avionics AeroLED MGL Avionics Leading Edge Airfoils Desser CPS Parts EarthX Batteries
Results 1 to 5 of 5

Thread: Icom A6 headset problems

  1. #1

    Join Date
    Dec 2009
    Location
    Hickory, NC
    Posts
    63

    Default Icom A6 headset problems

    I just bought an Icom A6 for the Kitfox but when I try to use it with the headset addapter I get a loud squeal when I transmit. I've tried a couple of different headsets and an external antenna with the same results. Anyone else have any experience with this or suggestions?

    EG

  2. #2

    Join Date
    Sep 2012
    Location
    Scandia, MN
    Posts
    53

    Default Re: Icom A6 headset problems

    Try setting the sidetone to 0. If you don't, and use the headret boom mike, your transmitted voice also comes out over the speaker of the A6. I forget how, but I remember I found instructions in the manual. Let me know if that solves your problem.

  3. #3
    Senior Member Norm's Avatar
    Join Date
    May 2013
    Location
    Airdrie, North of Calgary
    Posts
    320

    Default Re: Icom A6 headset problems

    I know this is a really old post but in the hopes of helping others with an A6 here is what I have found. The A6 has an issue with sending the signal down the headset line causing feedback. I have been told it is because the battery is not a 12volt and can not supply proper power to a headset. On one friends installation we put a ferrite choke on the headset cable and it seemed to help. The solution most people use is to get rid of the A6 and find something else.

  4. #4

    Join Date
    Dec 2009
    Location
    Hickory, NC
    Posts
    63

    Default Re: Icom A6 headset problems

    I tried various solutions, none of which were ever really satisfactory. I ended up ditching the Icom and going to a different brand. I had read glowing reports on Icom but they really dropped the ball on the A6

  5. #5
    Senior Member
    Join Date
    May 2011
    Location
    MN
    Posts
    401

    Default Re: Icom A6 headset problems

    Yep, same here, read all the reviews on how great the Icom IC-A6 was also. Very dissapointed with it when using it in the plane. Ignition noise and feedback were impossible to totally elliminate. My old Champ was non-electric and I took a 6-7 hour cross-country with this radio...nearly drove me nuts.
    Works great for a carrying along while watching airshows/etc. but no matter what I tried I was not satisfied using it in the plane. Waste of money as far as I was concerned. Ended up putting my old King KX99 back in the plane for a back-up. Unfortunately it doesn't cover the newer range of frequencies.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •