Kitfox Aircraft Stick and Rudder Stein Air Grove Aircraft TCW Technologies Dynon Avionics AeroLED MGL Avionics Leading Edge Airfoils Desser CPS Parts EarthX Batteries Kitplane Parts
Results 1 to 5 of 5

Thread: Forward Elevator Push-Pull Tube Rubbing Center Seat belt Mount tab

  1. #1

    Join Date
    Oct 2019
    Location
    Noxon, MT
    Posts
    18

    Default Forward Elevator Push-Pull Tube Rubbing Center Seat belt Mount tab

    I have installed and rigged my elevator bell cranks and push rods. The final step for rigging is to check the flight controls for freedom of movement. While doing this I found that the forward elevator push-pull tube rubs on the underside of the center seat belt mounting bar.

    I tried shimming the bell crank inboard, no joy.

    What should I do?

    Here is a link to a video explaining: https://www.youtube.com/watch?v=Ha0ttT_6oms
    Roger
    Building
    STi, 912is

  2. #2
    Senior Member Delta Whisky's Avatar
    Join Date
    Dec 2017
    Location
    Amissville, VA
    Posts
    241

    Default Re: Forward Elevator Push-Pull Tube Rubbing Center Seat belt Mount tab

    Roger - just to be clear, did you rig the linkage (adjust travel via the limit stops) or have you just finished installing the linkage components?

  3. #3
    Senior Member
    Join Date
    Dec 2017
    Location
    Mapleton,UT
    Posts
    665

    Default Re: Forward Elevator Push-Pull Tube Rubbing Center Seat belt Mount tab

    Assuming your elevator is on and you set your throws and itís still hitting? You could try to shorten the control thatís hitting and lengthen the next one so you keep same amount of travel.
    Dustin Dickerson

    Building 7ss STI x 2
    Oratex
    29" shock monster
    EP912STI 155hp
    Garmin
    N33TF......FLYING!
    N53TF......Building

  4. #4

    Join Date
    Oct 2019
    Location
    Noxon, MT
    Posts
    18

    Default Re: Forward Elevator Push-Pull Tube Rubbing Center Seat belt Mount tab

    Quote Originally Posted by Delta Whisky View Post
    Roger - just to be clear, did you rig the linkage (adjust travel via the limit stops) or have you just finished installing the linkage components?

    Yes, The whole system is rigged and stops are set with 39degress up elevator and 20degrees down at the appropriate trim setting.


    I don't think shortening one rod end and lengthening another would work. Unless I maybe lengthen the middle elevator rod and shorten the front. I will give that a try tomorrow.
    Roger
    Building
    STi, 912is

  5. #5
    Senior Member
    Join Date
    Dec 2017
    Location
    Mapleton,UT
    Posts
    665

    Default Re: Forward Elevator Push-Pull Tube Rubbing Center Seat belt Mount tab

    If I recall that is what I had to do. I pretty much had to disregard all the measurements in the manual because they where off.
    Dustin Dickerson

    Building 7ss STI x 2
    Oratex
    29" shock monster
    EP912STI 155hp
    Garmin
    N33TF......FLYING!
    N53TF......Building

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •